test test ad

User Tag List

Results 1 to 7 of 7

Thread: CO2 Regulator Problem

  1. #1
    SCAPE Member Just Planted zipmaiflai's Avatar
    Member Since
    Nov 2014
    Location
    Garden Grove
    Posts
    47
    Post Thanks / Like
    Real Name
    Boris
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    CO2 Regulator Problem

    Hey everyone,

    I need some help. Was so excited to setup my CO2 system and flood my dry start tank today. However, when I went to connect my co2 tank and my regulator with solenoid, I realized something was wrong. The solenoid seems to have this extra protrusion so the fitting won’t sit flush with the tank. What do I need to do to fix this? Any help would be appreciated. Thanks!




    Sent from my iPhone using Tapatalk

  2. #2
    SCAPE Member Jr. SCAPEr Swank's Avatar
    Member Since
    Sep 2018
    Location
    Upland
    Posts
    96
    Post Thanks / Like
    Real Name
    Daniel
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Gonna have to swap out the stem to a cga-320 for co2. It's the wrong fitting, looks like a cga-350 from what I could find on google images.

  3. #3
    SCAPE Member SCAPEr kberg2498's Avatar
    Member Since
    Jan 2018
    Location
    Winnetka
    Posts
    311
    Post Thanks / Like
    Real Name
    Kyle B.
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Not certain but I think thats a European co2 connection lol. Had the same thing with my Chinese regulators I bought off ebay. You have to get a little adapter. I forget what the threading was called sorry D:

  4. #4
    SCAPE Member Just Planted zipmaiflai's Avatar
    Member Since
    Nov 2014
    Location
    Garden Grove
    Posts
    47
    Post Thanks / Like
    Real Name
    Boris
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Need some more help. I gave up on the old regulator, so I got a new regulator and was trying to install it, but gas was majorly leaking as in the picture below. I heard I might need a plastic washer of some sort? Please advise! Thanks in advance!




    Sent from my iPhone using Tapatalk

  5. #5
    SCAPE Member Just Planted zipmaiflai's Avatar
    Member Since
    Nov 2014
    Location
    Garden Grove
    Posts
    47
    Post Thanks / Like
    Real Name
    Boris
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)



    Sent from my iPhone using Tapatalk

  6. #6
    Pew Pew Lazor 5000 posts, Officially addicted to SCAPE! Zenzu's Avatar
    Member Since
    Mar 2012
    Location
    Dan's Garage
    Posts
    5,914
    Post Thanks / Like
    Real Name
    BUCK
    Mentioned
    46 Post(s)
    Tagged
    0 Thread(s)
    Looks like there is already a plastic washer in there. I would try swapping it out for a crush washer or a new plastic washer.

    When connecting, mate the faces together then pull the nut on the regulator forward and begin to tighten to ensure both surfaces remain seated.
    THE CAKE IS A LIE!

  7. #7
    SCAPE Member Jr. SCAPEr Swank's Avatar
    Member Since
    Sep 2018
    Location
    Upland
    Posts
    96
    Post Thanks / Like
    Real Name
    Daniel
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Get a new washer and make sure to tighten the hell out of it with a wrench. Make sure to leak test with soapy water, if it still leaks tighten it some more.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •